Riva CRM Integration - Documentation and Knowledge Base

Error: Unable to Connect to Exchange Due to Missing Timezone Information

Article ID: 262
Last updated: 30 Oct, 2023

Applies to Riva Cloud & Riva On-Premise when syncing Exchange On-Premise or Microsoft 365 mailboxes.
 

Issue

Users receive the following error when synchronizing appointments from Exchange:

[XA] Error occurred polling for changes Omni.Connection.Ews.EwsMissingTimezoneException:  Unable to connect to Exchange due to missing timezone information.  Please refer to these Knowledge Base articles (http://support.microsoft.com/  kb981793 and kb914387) for instructions on how to update the timezone  information on your Exchange server. IIS must be restarted after  applying the update. --->  Microsoft.Exchange.WebServices.Data.ServiceResponseException: The  specified time zone isn't valid.

Possible Causes

  • Incorrect timezone or system clock settings in Exchange, or on affected users' workstations;
  • Riva expects a Microsoft timezone-related patch to be present on the Exchange Server, but the patch is missing;
  • Riva is attempting to process a timezone that no longer exists, or is otherwise invalid.
  • The timezone set for the user in Exchange does not match the user's timezone in CRM.


First, verify the following:

  1. The timezones and system clock are correct in Exchange On-Premise Server or Microsoft 365, and on the affected users' machines.
  2. All updates from Microsoft have been applied to Exchange On-Premise Server or Microsoft 365 as applicable.
  3. The affected users' workstation time zone has been re-synced with the domain controller server, and its registry has been updated with the correct timezone information.
  4. The user's timezone in CRM matches the timezone in Exchange.

    If these steps have been performed and the error persists, perform the resolution steps below.


Resolution

For Riva Cloud, contact the Riva Success Team.

For Riva On-Premise, perform the steps below.


To resolve the missing timezone information error:

  1. Run a Fiddler trace to identify timezone(s) causing the error.
     
  2. Stop the Omni sync service, and follow the directions at How to Apply Advanced Options to an Exchange Connection in Riva to add the advanced option:
     

    <add key="Sync.Ex.InvalidTimezone.*Timezone identified from Fiddler*" value= "*Year reported in Fiddler" (example - 2009) />

  3. Relaunch the Riva Manager, and restart the sync service.

Article ID: 262
Last updated: 30 Oct, 2023
Revision: 8
Views: 5863
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