Riva CRM Integration - Documentation and Knowledge Base

Infor CRM (Saleslogix) Error: Unable to Find TimeZoneById 'NULL' for DbUserId

Article ID: 659
Last updated: 19 Mar, 2019

Issue

The Riva Service Monitor displays "Unable to find TimeZoneById 'NULL' for DbUserId". Examination of the crmex-log file reveals an error similar to this sample:

2012-01-23 05:00:00,133  INFO [CTP-rjr #820] [93722346] Establishing connection to Exchange [firstname.familyname@my.org].
2012-01-23 05:00:18,223 ERROR [CTP-rjr #820] [93722346] [CL: x054e74c7eca63913; M:get_xadc6b66722422820] Unable to find TimeZoneById 'NULL' for DbUserId 'UTTTTA00001S'
2012-01-23 05:00:18,223 ERROR [CTP-rjr #820] [93722346] Unable to determine CRM timezone for override.
System.TimeZoneNotFoundException: The time zone ID '' was not found on the local computer.

Cause

This error is being returned by the Infor CRM (Saleslogix) server and indicates that the timezone value is not specified for the target user account in the CRM.

Solution

Ask the user to specify their default timezone value in their Infor CRM (Saleslogix) account.

Applies to

  • Riva On-Premise for Infor CRM (Saleslogix).

Article ID: 659
Last updated: 19 Mar, 2019
Revision: 5
Views: 5806