Riva CRM Integration - Documentation and Knowledge Base

Salesforce Error: Unable to retrieve secondary entity connection

Article ID: 643
Last updated: 19 May, 2015

Customer reported an error attempting to synchronize to a Salesforce target user in a non-SSO environment.  Examination of the crmex-log file revealed the following error:

2011-11-22 09:23:16,112  INFO [CTP-byj #5] Establishing connection to Exchange [testuser@mycompany.com]..
2011-11-22 09:37:51,332 ERROR [CTP-byj #5] Unable to retrieve secondary entity connection with id salesforce://testuser@mycompany.com<>www.salesforce.com.

Cause

This error is normally caused when the Riva Salesforce connection for the target user recorded in the sync policy no longer exists.

Resolution

  1. In the Riva application, in the Setup tab, ensure that there is no Salesforce connection for testuser@mycompany.com<>www.salesforce.com.

  2. If a connection for Test User exists, double-click the connection object, and perform a connection test.  If it passes, go to step 4.  If it fails, try resetting the password, save the connection, double-click the connection, and perform another connection test. (For detailed instructions, see How to reset Salesforce password.)

  3. If no connection exists, run the Salesforce connection wizard, and create a connection for Test User. (For detailed instructions, see Create the Single-User Salesforce connection(s).)

  4. In the Policies tab, edit the sync policy for Test User.

  5. In the Policy Editor window, in the General tab, beside the "CRM Connection" field, click select >>, and select the correct connection for Test User. 

  6. Save the policy.

  7. Check the CRM Monitor to confirm that there are no errors for Test User to connect to Salesforce and that data sync has resumed.

Applies to

  • Riva to Salesforce - Single User Sync Policies

Article ID: 643
Last updated: 19 May, 2015
Revision: 1
Views: 4520