Riva CRM Integration - Documentation and Knowledge Base

Duration must be between 0 and 1440 minutes - Salesforce Error - [FIELD_INTEGRITY_EXCEPTION]

Article ID: 862
Last updated: 31 Oct, 2016

Issue

When Riva Cloud or Riva On-Premise attempts to sync multiday appointments (appointments that span two or more calendar days), an error similar to the following may occur.

2012-08-01 15:49:32,650 ERROR [CTP-xim #1596] [18HNG8F79NNK] [FIELD_INTEGRITY_EXCEPTION] Duration must be between 0 and 1440 minutes: Duration -- DurationInMinutes

Omni.Sync.ItemSyncException: [FIELD_INTEGRITY_EXCEPTION] Duration must be between 0 and 1440 minutes: Duration -- DurationInMinutes
 ---> Omni.Connection.Salesforce.SforceErrorResponseException: [FIELD_INTEGRITY_EXCEPTION] Duration must be between 0 and 1440 minutes: Duration -- DurationInMinutes

Cause

Salesforce is not configured for multiday spanning appointments, but Riva is. (For Riva On-Premise, this is possible in release 2.4.31 or higher.)

Solution

The solution is the same for Riva Cloud and Riva On-Premise, because it is implemented in Salesforce.

To configure Salesforce to support multiday events:

  1. Log in to Salesforce as an administrator.

  2. Select Setup > Customize > Activities > Activity Settings.

  3. Select the Enable Multiday Events check box, and select Submit.

    After the Salesforce Enable Multiday Event option is selected, Riva can support syncing to appointments with a duration of greater than 1440 minutes (24 hours).

Applies to

  • Riva Cloud.
  • Riva On-Premise 2.4.31 or higher.
  • Salesforce.

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Article ID: 862
Last updated: 31 Oct, 2016
Revision: 2
Views: 6406
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