Riva CRM Integration - Documentation and Knowledge Base

Error after user moved: Sync aborting - conflicting entity detected

Article ID: 1210
Last updated: 12 Oct, 2022

Applies to

  • Riva On Premise for Exchange.
  • Riva On Premise for Notes.

In rare circumstances, Riva admins have reported conflicting entity errors after moving users between sync policies using one of the following procedures:

In this example, the user Ian Sample is moved between Sync Policy East to Sync Policy West.  When Riva attempts to sync the user, a conflicting entity error is reported:

2015-02-23 12:18:46,359 ERROR [38] [(null)] Sync aborting - conflicting entity detected - EntityName: ian.sample@example.com, Policy: Sync Policy East, Conflicting Policy: Sync Policy West

Cause

This error occurs because the user's original sync destination is still in the Riva Global metadata.
 

Resolution

To resolve this error, the Riva Admin can perform an Override Conflicting Policy Safety re-initialization.

  1. Double-click the target policy to edit it.
     
  2. Select the users that were moved.
     
  3. Set Modules to All.
     
  4. Set Categories to All.
     
  5. Set Type to Override Conflicting Policy Safety.
     
  6. If a Policy Save Change Detection window appears, select Yes.
     
  7. Monitor user sync activity and confirm that there is no Sync aborting - conflicting entity detected error.

Article ID: 1210
Last updated: 12 Oct, 2022
Revision: 4
Views: 4013
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