Riva CRM Integration - Documentation and Knowledge Base

Upgrading to GoldMine 2014.2 Breaks Connection

Article ID: 1191
Last updated: 06 Feb, 2018

Issue

After upgrading to GoldMine 2014.2 or higher, users can see license errors in the CRM Service Monitor.

Cause

Upgrading GoldMine to 2014.2 or higher includes the use of a different License file (LicenseGM94.bin instead of LicenseGM.bin) and new license file serial numbers.

Riva is licensed to the GoldMine connection that was created on the basis of the old license file, but for GoldMine 2014.2 or higher, the new license file is expected. As a result, the connection does not work.

Solution

  1. Back up the custom settings on your current GoldMine connection.
  2. Create a replacement connection to GoldMine.
  3. Re-license Riva to use the new GoldMine license information.
  4. In every applicable policy, replace the old GoldMine connection with the new one.

To back up the custom GoldMine connection settings:

  1. In the Riva Manager application, in the top left corner, double-click the Riva logo.

  2. In the About Riva window that appears, in the top right corner, double-click the Riva version number.

    Result: Windows Explorer displays the Riva installation folder.

  3. Expand the Riva folder, and then copy the Custom folder and save it in a secure location.

To create a replacement connection to GoldMine:

  1. While creating a GoldMine connection, be sure to point to the new license file for GoldMine 2014.2 or higher.

  2. Navigate to the backup of the Custom folder that you made earlier.

  3. Copy the contents into the Custom folder of the new GoldMine connection.

To re-license Riva to use the new GoldMine license information:

  1. While requesting a new Riva license file, in the Comments area describe that the license request is for a "Replacement license request after GoldMine 2014.2 or higher upgrade".

  2. After receiving a new license by email, activate it.

In every applicable policy, replace the old GoldMine connection with the new one:

  1. In the Riva Manager application, on the menu bar, select Policies.

  2. In the right pane, double-click a sync policy that uses the connection that broke.

  3. In the window that appears, on the General page, to the right of the CRM Connection field, click Select.

  4. Select the new connection that uses the license file for GoldMine 2014.2 or higher.

  5. Save the policy.

  6. For every policy that used the connection that broke, repeat steps 2 to 5.

Applies to

  • Riva for GoldMine 2014.2 or higher.

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Article ID: 1191
Last updated: 06 Feb, 2018
Revision: 3
Views: 5074
Comments: 0
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