Riva CRM Integration - Documentation and Knowledge Base

Hosted Exchange Service Provider Reports Excessive Logging

Article ID: 294
Last updated: 15 Jun, 2016

Even when Riva On-Premise is correctly synchronizing data, an Exchange 2007 EWS hosted service provider might report excessive logging, as in the following example.

208.88.241.55 ExchangeServicesClient/14.00.0650.007 200 0 0
2010-12-21 16:16:11 W3SVC1 10.192.30.12 POST /EWS/Exchange.asmx - 443 - 208.88.241.55 ExchangeServicesClient/14.00.0650.007 401 1 0
2010-12-21 16:16:11 W3SVC1 10.192.30.12 POST /EWS/Exchange.asmx SoapAction=SyncFolderItems;Version=1;RpcC=6;RpcL=15;LdapC=0;LdapL=0; 443 sdncom\DSSuite 208.88.241.55 ExchangeServicesClient/14.00.0650.007 200 0 0

Symptoms

The connection editor tests the EWS connection against all the users successfully but fails in three ways.

  • Failures #1 and #2: Testing the EWS connection with the user name field (1) blank or (2) set to Domain\<username>. This causes the error "Connection Authentication Failed!  Usable to determine email for user: <username>".
  • Failure #3: Testing the connection by entering the email address <username>@mydomain.com. This causes the error "Connection Authentication Failed!  Unable to resolve mailbox: <username>@mycompany.com".

Cause

The error is caused when creating the EWS connection in the Riva application, specifically by using the email address of the connection account as provided by the service provider instead of using the NT LAN Manager (NTLM) or user principal name (UPN) of the user. Riva Exchange connections need to authenticate using the NTLM or UPN for the AD account that owns the Exchange mailbox for the connection account. With on-premises Exchange systems, the UPN and email address are usually the same. For hosted Exchange service providers, they are usually different.

Resolution

Modify the EWS connection to use the UPN of the connection account. The UPN can be one of the following:

  • DOMAIN\Username, for example, EXAMPLE\riva_svc; or
  • username@AD_Domain, for example, riva_svc@example.com.

To prevent the excessive logging error:

  1. Contact the Exchange service provider, and obtain the UPN for the Riva connection user.

  2. Start the Riva Manager application. On the menu bar, select Setup. In the right pane, double-click the Riva Exchange 2007 EWS connection to open the connection editor.

  3. In the Connection Details tab of the window that appears, modify the User Name and Password to match the NTLM or UPN username and password provided by the Exchange service provider.

  4. Save the connection.

  5. Re-open the Exchange connection, and perform a test without identifying an end user.

  6. Close the connection.

    Because a change is being made to an existing EWS connection, you do not need to reinitialize the accounts. The Riva On-Premise service detects the change and restarts automatically if required.

  7. After the changes are in effect, contact the Exchange service provider to verify if the connection issue is resolved.

Applies to

  • Riva On-Premise EWS connections
Article ID: 294
Last updated: 15 Jun, 2016
Revision: 5
Views: 6343
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