Riva CRM Integration - Documentation and Knowledge Base

Riva Delays Syncing Items between GroupWise 2012

Article ID: 1018
Last updated: 07 Oct, 2013

Several customers reported an issue with Riva not syncing calendar items for several hours after the user saved the create of a calendar item.  The customer was hosting GroupWise 2012 on OES Linux servers and the Riva 2.4.34.

Error in the Log

Examination of the crmgw log file revealed:

2013-08-22 11:10:54,225  WARN [CTP-cvx #2] [2DGLVCM50MBK] [CL: x9fdae50a113d65cc; M:x23165f9f28253d59] There is a large time difference between GroupWise and the CRM: -04:00:00
2013-08-22 11:10:54,225  INFO [CTP-cvx #2] [2DGLVCM50MBK] Local Time: 2013-08-22 11:10:54 CRM Time: 2013-08-22 11:10:54 GroupWise Time: 2013-08-22 07:10:54 Time Difference: -04:00:00 Processing Time: 0

Cause

This customer was located in Eastern US in "Eastern Time Zone" and the time zone offset between UTC and Eastern was 4 hours.  It appears that Riva was not picking up the correct time offset for GroupWise.

Internal lab testing confirmed that this issue only affects GroupWise 2012.  Earlier versions of GroupWise do not suffer from the same errors.

Resolution

The following procedure has resolved this issue for several customers:

  1. Upgrade Riva to 2.4.35+.

  2. On the server hosting GroupWise, set the local clock to use UTC.

  3. On the server hosting GroupWise, ensured that ntp is using local time (e.g. Central)

  4. On the server hosting GroupWise, the OS time is set to local time (e.g. Central)

  5. Add or modify the Omni.Riva.CrmAgent.exe.config file to include only highlighted line from this example:

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <appSettings>
        <add key="GwSoap.GetServerTime.UseServerLocal" value="True" />
      </appSettings>
    </configuration>

  6. In the CRM Monitor application, RESTART the sync service.
  7. After a sync cycle for a user completes, check the newest crmgw-log file and confirm that there are no "large time difference" errors.

Applies to

  • Riva On Premise for GroupWise 2012 and Salesforce
Article ID: 1018
Last updated: 07 Oct, 2013
Revision: 1
Views: 4534
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