Riva CRM Integration - Documentation and Knowledge Base

CRM Connection Error: Connection Not Found! Unable to Retrieve Secondary Entity Connection

Article ID: 944
Last updated: 28 May, 2019

Issue

Connection errors occur for the CRM connections for every user. The crmex-log file contains errors similar to these:

2013-05-22 14:31:13,863 TRACE [CTP-app #0] [1VT56PFD8R2A] Retrieving connection from connection manager: sugarcrm://admin<>crm.example.com

2013-05-22 14:31:13,863 TRACE [CTP-app #1] [26CUASNLCHDT] Retrieving connection from connection manager: sugarcrm://admin<>crm.example.com

2013-05-22 14:31:13,863 ERROR [CTP-app #1] [26CUASNLCHDT] Connection Not Found! Unable to retrieve secondary entity connection. Id=sugarcrm://admin<>crm.example.com

2013-05-22 14:31:13,863 ERROR [CTP-app #0] [1VT56PFD8R2A] Connection Not Found! Unable to retrieve secondary entity connection. Id=sugarcrm://admin<>crm.example.com

2013-05-22 14:31:13,863  INFO [CTP-app #2] [1OCB1YYRQLTS] Total Synchronization Time: 0 secs.  (2:31:13 PM)

2013-05-22 14:31:13,863  INFO [CTP-app #1] [26CUASNLCHDT] Aborting sync: Connection Not Found! Unable to retrieve secondary entity connection. Id=sugarcrm://crm.example.com

2013-05-22 14:31:13,863  INFO [CTP-app #0] [1VT56PFD8R2A] Aborting sync: Connection Not Found! Unable to retrieve secondary entity connection. Id=sugarcrm://admin<>crm.example.com

2013-05-22 14:31:13,863  INFO [CTP-app #2] [1OCB1YYRQLTS] Synchronization Completed in 0 secs.  (2:31:13 PM)

Cause

The sync policy's CRM connection object is trying to connect to the CRM with a connection for "sugarcrm://admin<>crm.example.com" that may no longer exist.

Solution

If the CRM connection was modified or replaced, it needs to be refreshed in the sync policy.

To refresh the CRM connection in the sync policy:

  1. In the Riva Service Monitor application, stop the service.

  2. In the Riva Manager application, on the menu bar, select Policies. Edit the sync policy.

  3. On the General page, look to the right of the CRM Connection field, and select the select >> link.

    Result: The CRM connection is refreshed to use what is available or present a list of possible CRM connections to choose from.

  4. Save the sync policy. If prompted to restart the sync service, select Yes.

  5. In the Riva Service Monitor, confirm that the sync has started again, and confirm that there are no CRM connection errors.

Applies to

Article ID: 944
Last updated: 28 May, 2019
Revision: 4
Views: 4074