Riva CRM Integration - Documentation and Knowledge Base

Solution for: Unable to Browse GroupWise Users Under PO in Tree Browser

Article ID: 88
Last updated: 26 Oct, 2015

Issue

When I want to select GroupWise users using the post office browser, nothing happens:

I have to use the eDirectory browser to see my users.

Cause

The reason you cannot see user objects below the Post Office is that there is a configuration challenge with the Riva GroupWise connection to the Domain. Riva needs to have file system access to the wpdomain.db file of the GroupWise domain, which must be hosted on an NSS volume.

Resolution

See Step 3 - Create Riva On-Premise GroupWise Connections, on pages 10 - 19 of the Riva Integration Server for GroupWise Admin Guide:

  • If you are using a trusted application key, the wpdomain.db file for the domain needs to be located on an NSS volume (or an NCP mount share). In addition, the Options need to be properly configured (steps 20 to 23 on page 15 of the Admin Guide). OR
  • If the Domain is not hosted on an NSS volume, then you can choose to create a Direct GroupWise connection by using a GroupWise account that has full proxy access to the target GroupWise accounts that will synch data to SugarCRM. In that case, see How to Create a Direct / Private Connection to a Target GroupWise System, on pages 16 to 19 of the Admin Guide.

Finally, Riva works more efficiently if you select the eDirectory user objects for the GroupWise accounts that you wish to sync with SugarCRM. When selecting target users, choose to browse through the eDirectory tree instead of choosing the GroupWise post office object.

Applies to

  • Riva On-Premise for GroupWise

Article ID: 88
Last updated: 26 Oct, 2015
Revision: 2
Views: 5292
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