Riva CRM Integration - Documentation and Knowledge Base

Error Occurred Synchronizing Attachments

Article ID: 2401
Last updated: 29 Jun, 2023

Applies to Riva Cloud & Riva On-Premise, when attachment sync is enabled for any module.

Background info: Manage Attachment Filter Options.

Issue

Attachment sync fails with an error in user logging similar to the one below:

2023-02-13 05:01:09Z : [49TVAK4FKPJH8] Error - Error occurred synchronizing attachments


 

Potential Causes

To help narrow down the scope of the issue, ask the following questions:

  • Is the error happening for one user, a few, or all?
  • Does the error tend to happen for certain file types?
  • Does the error seem to occur for attachments above a certain file size?

To diagnose the root cause, use CRMEX logging; if the root cause is still not apparent, capture a Fiddler trace while syncing the affected attachment.

 

Solution

The solution will vary, depending on the cause.

 

Scenario 1: 503 Server Unavailable

CRMEX logging or a Fiddler trace of failed attachment sync shows an error like the one below: 

2023-02-16 14:47:57,209 ERROR [CTP] [1TRAF9DZT2VQA] Error occurred synchronizing attachments ...
 ---> System.Net.WebException: The remote server returned an error: (503) Server Unavailable.

  1. If this key is present in the sync policy advanced options or CRM connection advanced options, ensure that the URL value is correct:

Sync.Crm.CustomAttachmentUploader.Host = https://correct-url-of-uploader.com

  1. If the URL is correct, ensure that the endpoint is online and reachable. 
    More info: (Mozilla) 503 Service Unavailable.
     

Scenario 2: Attachment is corrupted

This scenario is most likely if only one attachment seems to be affected.
In this case, attempt to sync a new version of the file.
 

Scenario 3: Permissions issues in CRM

Use CRMEX logging & a Fiddler trace of the failed attachment sync to diagnose & identify missing permissions in CRM.



Scenario 4: Attachment size exceeds CRM limits

To resolve, either decrease the attachment's file size OR increase allowed size of attachments in CRM.

Scenario 5: Attachment has invalid characters in its filename

To resolve, rename the file so as to remove the invalid characters.

Article ID: 2401
Last updated: 29 Jun, 2023
Revision: 9
Views: 0