Issue
In older versions of Riva, the following error may appear in the sync logs.
Error: Skipped Appointment in Exchange - Skipping cancelation of already canceled appointment
Cause
When synchronizing with the CRM, Riva detected that there was a deletion in the CRM. To process the deletion, Riva first attempted to find the item in Exchange, but it was discovered that the appointment in Exchange was already cancelled. Riva skipped the deletion, because the appointment was already cancelled in Exchange.
Solution
Upgrade Riva On-Premise to the latest public release.