Riva CRM Integration - Documentation and Knowledge Base

Riva Data Sync Error: Missing Master Item ID for Occurrence

Article ID: 1016
Last updated: 23 Jun, 2016

A customer reported seeing the a "[CA] Error - Missing master item ID for occurrence" in the CRM Monitor application for a specific user.

Error in the Log

Examination of the crmex-log file revealed the following error:

2013-08-31 18:46:35,396 ERROR [CTP-cva #0] [272NFORWT6V6] Missing master item ID for occurrence.
Omni.Sync.ItemSyncException: Missing master item ID for occurrence.
2013-08-31 18:46:35,396  INFO [CTP-cva #0] [272NFORWT6V6] [CA] Error - Missing master item ID for occurrence.: FW: Discuss structure and contracts necessary for MS [XA418]

Cause

This error indicates that there is a recurring appointment titled “FW: Discuss structure and contracts necessary for MS” and Riva cannot find the original appointment in the series. This means that Riva was not able to find the "parent" appointment to a recurring series in the users Exchange mailbox when trying to update one of the child entries.

Solution

The way to fix this issue is to find the original appointment in the Exchange series and update it.

Applies to

  • Riva for Exchange
Article ID: 1016
Last updated: 23 Jun, 2016
Revision: 2
Views: 4415