Issue
The CRM connection error "Multiple possible User matches" may occur.
2012-05-01 16:39:49,920 INFO [CTP-seo #0] [1869879180] Establishing connection to SugarCRM [IMPERSONATION]...
2012-05-01 16:39:55,769 INFO [CTP-seo #0] [1869879180] [xa9a2e5757c5542ef, x6036ca329a7e65e9] Connected! admin via http://10.10.0.120:8080/soap.php (6.3.2:pro)
2012-05-01 16:39:56,750 INFO [CTP-seo #0] [1869879180] [xa9a2e5757c5542ef, GetEntry] Retrieving; Users/1
2012-05-01 16:39:57,751 INFO [CTP-seo #0] [1869879180] [xa9a2e5757c5542ef, GetEntry] Retrieved; Users/1
2012-05-01 16:40:04,902 ERROR [CTP-seo #0] [1869879180] [CL: xa9a2e5757c5542ef; M:xfa97a89b2239dd3a] Multiple possible User matches found for UserId:rgordon@mycompany.com; Email:rgordon@mycompany.com
2012-05-01 16:40:04,902 ERROR [CTP-seo #0] [1869879180] [CL: xa9a2e5757c5542ef; M:xfa97a89b2239dd3a] id = '1', user_name = 'admin', first_name = 'System', last_name = 'Administrator', status = 'Active', email1 = 'rgordon@mycompany.com', is_group = '0'
2012-05-01 16:40:04,902 ERROR [CTP-seo #0] [1869879180] [CL: xa9a2e5757c5542ef; M:xfa97a89b2239dd3a] id = 'aa7c30e9-8cd4-797b-cae8-4c0eab9df949', user_name = 'rgordon', first_name = 'Rob', last_name = 'gordon', status = 'Active', email1 = 'rgordon@mycompany.com', is_group = '0'
2012-05-01 16:40:04,902 ERROR [CTP-seo #0] [1869879180] [CL: xa9a2e5757c5542ef; M:xfa97a89b2239dd3a] id = 'b8c30fa2-471e-d359-7985-4a8340a1f8d1', user_name = 'Pacific Salesrep', first_name = 'Pacific', last_name = 'Salesrep', status = 'Active', email1 = 'rgordon@mycompany.com', is_group = '0'
2012-05-01 16:40:04,902 INFO [CTP-seo #0] [1869879180] Connection to CRM Server failed: Multiple possible User matches found for UserId:rgordon@mycompany.com; Email:rgordon@mycompany.com
2012-05-01 16:40:04,912 INFO [CTP-seo #0] [1869879180] Total Synchronization Time: 19 secs. (4:40:04 PM)
2012-05-01 16:40:04,912 INFO [CTP-seo #0] [1869879180] Synchronization Completed in 19 secs. (4:40:04 PM)
2012-05-01 16:40:04,912 ERROR [CTP-seo #0] [1869879180] Minor error occurred during synchronization.
Omni.Scheduling.SchedulePostponeException: Multiple possible User matches found for UserId:rgordon@mycompany.com; Email:rgordon@mycompany.com ---> System.UnauthorizedAccessException: Multiple possible User matches found for UserId:rgordon@mycompany.com; Email:rgordon@mycompany.com
2019-05-30 21:30:08.001 day@mycompany.com Connection to CRM Server failed: [CannotImpersonate] Multiple possible user matches for impersonation: day@mycompany.com
Cause
In the sample errors, three CRM user accounts — 'admin', 'rgordon', and 'Pacific Salesrep' — were found to be using the same email address, rgordon@mycompany.com. It was, therefore, impossible to determine which CRM account to sync to, and the sync to the CRM failed.
Note: The identity of the multiple CRM users who use the same email address is indicated only if the web services API supports providing that information.
This error often occurs when a CRM admin's email address is assigned to both the admin account and the admin's personal CRM account. In one of the above errors, a generic CRM account to handle Pacific Salesrep was also configured with the same email address.
If syncing from one email address to multiple CRM accounts were supported, the sync would create duplicate items in the CRM. To prevent such duplicates, the sync error occurs.
Solution
To correct the issue, ensure that all CRM users are configured with unique email addresses.
Applies to
- Riva Cloud.
- Riva On-Premise.