Riva CRM Integration - Documentation and Knowledge Base

Oracle CRM On Demand: (503) Server Unavailable Error

Article ID: 597
Last updated: 24 Oct, 2016

Issue

In Riva Cloud or Riva On-Premise, "(503) Server Unavailable" errors may sporadically appear throughout crmex-log files.

2011-11-22 10:06:17,054 ERROR [CTP-jwc #814] [909838433] Minor error occurred during synchronization.
Omni.Scheduling.SchedulePostponeException: The remote server returned an error: (503) Server Unavailable. ---> System.Net.WebException: The remote server returned an error: (503) Server Unavailable.

Cause

Oracle CRM On Demand imposes a set of "web services on demand limiters" that can limit

  • the total number of concurrent requests for data,
  • the maximum values for records, and
  • the volume of data requested.

If the total volume of data being requested or synced during a Riva sync cycle exceeds the permitted threshold value, Oracle On Demand web services report that the server is unavailable.

Solution

  • If this issue if a low occurrence error, it can be safely ignored.
  • If the issue becomes pronounced, adjustments need to be made to reduce the number of requests and volume of data syncing.

Solution for Riva Cloud

Solution for Riva On-Premise

Reducing the number of requests and/or volume of data syncing can be accomplished in several ways, including:

This article was:   Helpful | Not helpful
Report an issue
Article ID: 597
Last updated: 24 Oct, 2016
Revision: 3
Views: 6060
Comments: 0
Also listed in