Issue
In Riva On-Premise, the same user keeps generating the following error repeatedly, quickly filling up the log files.
2011-08-02 13:39:51,046 ERROR [CTP-zgp #1] **** EXCEPTION ****************************************************************************************************
2011-08-02 13:39:51,046 ERROR [CTP-zgp #1] * Omni.Sync.ItemSyncException: [0x80040217:appointment] systemuser With Id = 9568afcb-454e-e011-a3ba-00155d007b10 Does Not Exist
Cause
The issue has a combination of two causes:
- Riva On-Premise mapped an appointment recipient to a user id that does not exist in the CRM. The user may have been deleted and recreated, or just removed from the CRM.
- You are using an old version of Riva On-Premise, because this error does not occur in recent versions.
Solution