Riva CRM Integration - Documentation and Knowledge Base

Riva Insight: HTTP Error 404.7 - Not Found The request filtering module is configured to deny the file extension

Article ID: 2373
Last updated: 09 Mar, 2023

Applies to Riva Insight Server, Web add-in & Outlook add-in.


Issue

When using Riva Insight for Outlook, an error appears in context view:
 

HTTP Error 404.7 - Not Found 
The request filtering module is configured to deny the file extension.


On the IIS server hosting Insight, when browsing the localhost site, an error webpage appears instead of the Riva Insight login screen:

Cause

The IIS server hosting Insight may be set to disallow all file extensions and verbs.

Solution

To allow the required extensions:

  1. On the server hosting Riva Insight, start IIS Manager.
     
  2. In the left pane, under Connections, expand the Sites drop-down and select the Riva Insight website.
     
  3. In the middle Home pane, select Request Filtering.
     
  4. In the right pane, under Actions, select Edit Feature Settings.
     
  5. Check the two boxes to Allow unlisted file name extensions and Allow unlisted verbs. Select OK.
     
  6. In the left Connections pane, under Start Page, select the server name. In the right pane, under Manage Server, select Restart.
     

Expected result: The localhost/Insight page on the IIS server should show the login page upon reloading; likewise, if the end user restarts Outlook, the Riva Insight login page should appear normally in context view.

This article was:   Helpful | Not helpful
Report an issue
Article ID: 2373
Last updated: 09 Mar, 2023
Revision: 5
Views: 0
Comments: 0