Riva CRM Integration - Documentation and Knowledge Base

Revalidate an Exchange OAuth Connection in Riva On-Premise

Article ID: 2364
Last updated: 19 Oct, 2022

Applies to Riva On-Premise with OAuth connections to Exchange.

 

Issue

All users fail to sync with the following error:

2022-10-19 16:21:07Z : [3KCGL6S9IGCNF] Establishing connection to Exchange [exampleuser@company.com]..
2022-10-19 16:21:07Z : [3KCGL6S9IGCNF] Refresh oauth access token failed.

Cause

The OAuth token for the Exchange connection has expired.

Solution


To re-validate the token for an OAuth connection to Exchange:

  1. Open the Riva Manager application, and select (double-click)  the Exchange connection.
     
  2. On the Connection Details tab, under Authentication Details, select the Validate OAuth Tokens button.
     
  3. If successful, a pop-up window appears indicating that the OAuth token has been revalidated.



     
  4. Save the connection.

    If the revalidation fails, double-check the Authentication Details on the Connection Details tab.
     

If revalidation continues to fail, contact the Riva Success Team.

Article ID: 2364
Last updated: 19 Oct, 2022
Revision: 3
Views: 0