Riva CRM Integration - Documentation and Knowledge Base

Riva Insight: No such column 'Field__c' on entity 'Object__c'

Article ID: 2279
Last updated: 10 Jun, 2022

Applies to Riva Sync & Riva Insight for Salesforce.

Issue

Riva Insight displays an error similar to the one shown: 

Riva Manager logs also show the error:

---> System.ServiceModel.FaultException`1[Omni.Sync.Crm.Sdk.Service.ErrorInfo]: [Unknown] No such column 'Field__c' on entity 'Object__c' at Row:1 Column:77.  If you are attempting to use a custom field, be sure to append the '_c' after the custom field name.

Cause

A custom field referenced in the error message is either missing, present when it shouldn't be, or not set correctly on the associated object in the Riva sync policy's CRM connection.

Solution

  1. Determine whether the field is needed or not.
    1. For example, if your sync policy is not configured to sync Leads, Riva should not query Lead fields.

       
  2. Remove it from the CRM connection object definition in the Riva Manager if not needed; alternatively, add it (with correct spelling) if it is supposed to sync.
     
  3. If the field is needed, and present in the CRM connection object definition, add the field to the object in CRM.

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Article ID: 2279
Last updated: 10 Jun, 2022
Revision: 7
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