Riva CRM Integration - Documentation and Knowledge Base

Troubleshooting SessionID Errors When Extending a Trial Licence in Riva On-Premise

Article ID: 2052
Last updated: 05 Nov, 2020

Audience: Riva On-Premise administrators.

Issue

When generating a licence extension in Riva On-Premise, the wizard may return the following error:

Unable to generate licence for selected domains. Please verify your connection parameters. INVALID_SESSION_ID: Invalid Session ID found in SessionHeader: Illegal Session

Cause

This error may arise when the email connection has stopped functioning. Typically, this is the result of a password change or user name update.

Solution

Riva On-Premise email connections need to be manually updated if the username or password has changed.

  1. Open the Riva Manager application. In the right pane, double-click the appropriate email connection to edit it.

  2. In the Connection Edit window that appears, on the menu, select Connection Details. In the right pane, update the user name or password as required.

  3. On the menu, select Test. In the right pane, click Run Test.

    Result: The test verifies whether the email connection details have been configured correctly.

  4. If the test is successful, run the Licence Extension wizard again.

    Expected result: The wizard successfully generates a licence extension.

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Article ID: 2052
Last updated: 05 Nov, 2020
Revision: 12
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