Riva CRM Integration - Documentation and Knowledge Base

WindowsAD Authentication > "An error occurred in authentication" | "The server is not operational" Errors

Article ID: 1983
Last updated: 26 Apr, 2021

Riva Insight On-Premise

  • Configured to use WindowsAD Authentication.

Situation

With Riva Insight OnPremise using Windows Authentication, you may get an "An error occurred in authentication please contact your Riva administrator" error in Riva Insight, and a  "The server is not operational" error in the logs.

Error 

The following may appear in the Insight Server Logs: 

System.Runtime.InteropServices.COMException (0x8007203A): The server is not operational.
   at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
   at System.DirectoryServices.DirectoryEntry.Bind()
   at System.DirectoryServices.DirectoryEntry.get_AdsObject()


Cause

Possible causes include:

  1. The Windows Active Directory (AD) Server is down or unreachable.
  2. Network Issue (could not resolve DNS name).
  3. The server hosting Riva Insight lost communication with Active Directory (AD) Server.

Solution

The solution may differ depending on the cause:

  1. Try restarting the server hosting Riva Insight to try and re-establish communication.
  2. Verify the Windows AD Server is running.
  3. Ensure that the Windows AD Server is accessible from the server hosting Riva Insight.
This article was:   Helpful | Not helpful
Report an issue
Article ID: 1983
Last updated: 26 Apr, 2021
Revision: 3
Views: 11
Comments: 0