With Riva Insight OnPremise using Windows Authentication, you may get an "An error occurred in authentication please contact your Riva administrator" error in Riva Insight, and a "The server is not operational" error in the logs.
Error
The following may appear in the Insight Server Logs:
System.Runtime.InteropServices.COMException (0x8007203A): The server is not operational.
at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
at System.DirectoryServices.DirectoryEntry.Bind()
at System.DirectoryServices.DirectoryEntry.get_AdsObject()
Cause
Possible causes include:
The Windows Active Directory (AD) Server is down or unreachable.
Network Issue (could not resolve DNS name).
The server hosting Riva Insight lost communication with Active Directory (AD) Server.
Solution
The solution may differ depending on the cause:
Try restarting the server hosting Riva Insight to try and re-establish communication.
Verify the Windows AD Server is running.
Ensure that the Windows AD Server is accessible from the server hosting Riva Insight.