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Riva Insight: The User Domain [Your-Domain] It's Not Configured. Please Contact Your Riva Administrator. Try Again

Article ID: 2158
Last updated: 21 Oct, 2021

Applies to Riva Insight Server when using WindowsAD or DirectoryForms authentication.

Issue

When logging into Riva Insight in Outlook, the following error message appears:

You will also see the following message displayed in the Riva Insight server logs:

The user domain [YOUR-DOMAIN] it's not configured. Please contact your Riva Administrator.

Cause

When users log in with an account from an Active Directory domain other than the domain of the server that Riva Insight is installed on, the connection string must be present in the Riva Insight Server's /Insight/webConnectionStrings.config file for Riva Insight to connect properly. 

Each differing domain used requires its own string to be added to the file.

Common issues include:

  • The LDAP connection string is missing,
  • the string used is the wrong type for your configuration,
  • it contains a typo, or
  • it is commented out.

Solution

For server errors in Riva Insight for Outlook, try loading Insight directly from a browser window to see more detailed error information.

For Windows Active Directory authentication, the connection string must be in the following format with connection values filled in. These are denoted by the curly braces {} (omit the braces from the string):

<add name="LDAP:\{yourDomain}" connectionString="Host={loginServerNameOrIP};Port=636;UseSSL=true;SearchScope={dc=yourDomain,dc=yourDomainSuffix};Username={account};Password={password}"/>

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Article ID: 2158
Last updated: 21 Oct, 2021
Revision: 17
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Comments: 0