Riva CRM Integration - Documentation and Knowledge Base

Error: Account Does Not Have Permission to Impersonate Requested User

Article ID: 1925
Last updated: 31 May, 2019

Issue

The Riva logs may contain one or both of the following errors:

The account does not have permission to impersonate the requested user.

Unable to initialize: The account does not have permission to impersonate the requested user.

Cause

These errors occur when the Exchange connection user does not have impersonation permissions or delegate access for the syncing user.

Solution

Provide impersonation rights on Office 365, Exchange on-premises Server, and/or Hosted Exchange Services.

For Exchange online (Office 365):

For Exchange on-premises:

For Hosted Exchange Services:

Applies to

  • Riva Cloud.
  • Riva On-Premise.

Article ID: 1925
Last updated: 31 May, 2019
Revision: 3
Views: 1196
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