Solution for a Line Break / Carriage Return Issue (CRM & Outlook/Exchange)

Article ID: 448
Last updated: 25 Oct, 2016

Issue

When the descriptions of tasks or events created in Sugar or Salesforce contain line breaks and Riva Cloud or Riva On-Premise syncs the tasks or events to Exchange, the task or event descriptions in Outlook do not contain the line breaks.

Other CRMs may also be affected when syncing with Exchange.

Example:

Original text in the CRM:
TEST1.
Test2.
This is the 3rd line.

Text displayed by Outlook:
TEST1.Test2.This is the 3rd line.

Cause

A bug in Outlook's automatic conversion from plain text to RTF is causing the problems.

Riva is not changing the format. Riva does transmit the correct plain text from the CRM to Exchange.

Solution

Riva has developed a work around that prevents the bug in Outlook from dismissing the line breaks.

Solution for Riva Cloud

To preserve the line breaks:

Solution for Riva On-Premise

To preserve the line breaks:

Sync.Ex.AutoCorrectBodyFormattingByHtmlConversion.Appointment = TRUE

Sync.Ex.AutoCorrectBodyFormattingByHtmlConversion.Task = TRUE

This article was:   Helpful | Not helpful Report an issue


Article ID: 448
Last updated: 25 Oct, 2016
Revision: 15
Views: 5230
Comments: 0
Also listed in
folder Riva On-Premise - CRM Sync -> Manage Riva On-Premise (Admin Guides) -> CRM Systems -> Salesforce -> Advanced Options & Settings -> Misc.
folder Riva On-Premise - CRM Sync -> Manage Riva On-Premise (Admin Guides) -> CRM Systems -> Sugar -> Advanced Options & Settings
folder Riva On-Premise - CRM Sync -> Manage Riva On-Premise (Admin Guides) -> Email Systems -> Exchange (EWS) -> Advanced Options & Settings
folder Riva Cloud - CRM Sync -> Already Started -> Manage Your CRM for Riva -> Sugar -> Advanced Options & Settings

Prev     Next
Riva Support for Salesforce Person Accounts       Salesforce: Enable Syncing of Contact Photos


Back to Top