Riva CRM Integration - Documentation and Knowledge Base

Outlook crashes upon sign-in to Salesforce with Riva Insight

Article ID: 2316
Last updated: 08 Apr, 2022

Applies to Riva Insight Windows Add-in using Login with Salesforce.

Issue

While logging in to Riva Insight using Salesforce authentication, the Outlook desktop application crashes.

Cause

The problem was traced to Microsoft's update of the WebView2 runtime (Evergreen) to version 100.0.1185.29 from version 99.0.1150.55. The issue is related to the pop-up window that appears when using Login with Salesforce.

The Salesforce login form used in Riva Insight utilises the affected WebView2 runtime in this pop-up window.
 

Solution

Microsoft has implemented a fix for the issue, and will start rolling out the fix starting Thursday April 14th.
 

There are temporary workarounds in progress:

Riva Insight Cloud customers

For Riva Insight Cloud customers, our development team has a temporary workaround to disable the pop-up window for Login with Salesforce in Riva Insight.

Riva Insight will be rolling out the fix to Cloud Customers on the  US/CA/EU/AU data centres starting the evening of Monday April 11th.

You do not need to take any action on your side.

Riva Insight Server On-Premise customers

For Riva Insight Server On-Premise customers, perform the following steps:

  1. Add the following key to \Insight\App_Data\AppSettings.xml, then save the file:

<add key="Insight.Auth.Salesforce.DisablePopup" value="true" />

This key will disable the login pop-up when users log in to Riva Insight with Salesforce. End users will not see a pop-up window when they log in.

  1. Restart IIS.

If the issue persists after performing these steps, contact the Riva Success Team.

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Article ID: 2316
Last updated: 08 Apr, 2022
Revision: 11
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