Riva CRM Integration - Documentation and Knowledge Base

Sage CRM: Date Received As Unspecified and No Timezone Set

Article ID: 1641
Last updated: 27 Oct, 2017

Issue

The following error may occur when Sage CRM is synced by Riva On-Premise 2.4.43.37163 or higher:

Date received as Unspecified and no timezone set. Update Sage Web Service settings to return times in universal time or set Sage.LocalTimeZone.

Causes

There is a twofold cause:

  • The date is received from Sage CRM as Unspecified, because in Sage, the setting Send and return all dates and times in universal time is set to No; and
  • In Riva, there is no timezone set for the Sage CRM connection.

If either portion of the cause is resolved, the error is prevented from reoccurring.

Possible Solution #1

  • Configure the Sage Web Services setting Send and return all dates and times in universal time to Yes. How to access that setting.

Possible Solution #2

Set a timezone for the Sage CRM connection.

How to do it for Riva Cloud

How to do it for Riva On-Premise

(Riva On-Premise 2.4.43.37163 or higher.)

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Article ID: 1641
Last updated: 27 Oct, 2017
Revision: 7
Views: 3524
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