Riva CRM Integration - Documentation and Knowledge Base

Fix for [Contact] Error - Error Occurred Updating Item: [FIELD_INTEGRITY_EXCEPTION]

Article ID: 1601
Last updated: 14 Feb, 2017

Issue

In Riva Cloud or in Riva On-Premise, the following sync error may occur:

[Contact] Error - Error occurred updating item: [FIELD_INTEGRITY_EXCEPTION] There's a problem with this state, even though it may appear correct. Please select a state from the list of valid states.: Other State/Province -- OtherState

Cause

State and Country pick lists have been enabled in Salesforce, but the support for those pick lists has not been enabled in Riva.

Solution

Solution for Riva Cloud

Solution for Riva On-Premise

To support state and country pick lists:

  1. Determine which Riva On-Premise version is installed. If it is not at least 2.4.39.24713, upgrade Riva to the latest public release, unless a Riva staff member advises you to do otherwise.

  2. Apply the following advanced custom option to the Salesforce connection:

    Sync.Crm.Contact.StateCountryPickList.Supported = true

  3. Reopen the Salesforce connection.

  4. Navigate to the Object Definition page. Near the top, select Refresh.

  5. Save the CRM connection.

    Note: After you apply this option, users must create or update their syncable email contacts with the exact State and Country values that are specified in the Salesforce contact pick lists. If an invalid value is entered, a sync error occurs when trying to create or update the contact in Salesforce.

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Article ID: 1601
Last updated: 14 Feb, 2017
Revision: 4
Views: 5688
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