Error: Unable to initialize: Attempt to write to read-only database

Article ID: 935
Last updated: 10 May, 2019

Customer reported an issue when starting the Riva service in the Riva CRM Service monitor:

Symptoms

  • Riva is not able to initialize a sync cycle while trying to write to a read-only database.

Possible Causes

  • The user is logged in as a normal user when the Riva service is started.  The Riva CRM Agent service is configured to logon as the SYSTEM user which may not have sufficient file system permissions to write to files in the \Riva\Application folder structure, or
  • AV software might be preventing Riva from opening and writing to files in the \Riva\Application folder structure

Resolution

  1. Configure the Riva CRM Agent service to logon as a local or AD user that is a member of the Local Administrators group on the Windows system hosting Riva.
  2. Configure the AV software to exclude the \Omni\Riva folder structure, and to exclude and .exe and .dll files under the \Riva\Application child folders.


Article ID: 935
Last updated: 10 May, 2019
Revision: 2
Views: 4396
Also read
item Riva Sync Service: Install or Reinstall; Configure Properties
item Configure Anti-Virus Software for Riva On-Premise

Also listed in
folder Riva On-Premise - CRM Sync -> Manage Riva On-Premise (Admin Guides) -> Manage the Riva Server -> Manage Server Configuration -> Errors & Troubleshooting

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