Riva CRM Integration - Documentation and Knowledge Base

NetSuite: Insufficient permissions for the NetSuite Webservice Call

Article ID: 576
Last updated: 20 Oct, 2016

Issue

When Riva Cloud or Riva On-Premise tries to sync target users, the "insufficient permissions for the NetSuite WebService call" error may occur.

Cause

Normally, NetSuite end users are assigned a role with limited permissions that might not be enough for Riva sync.

Solution

The solution is to create another role with all necessary permissions for the Riva sync call to be executed successfully.

Step 1: Create a role (webservices only) with sufficient permissions for Riva Sync

  1. Log in to NetSuite with an administrator account.

  2. Navigate to Setup > Users/Roles > Manager Roles > New to create a new role.

  3. Give sufficient permissions to this role, and select the Web Services Only Role check box. Save the role.

  4. Navigate to Setup > Users/Roles > Manager Users, select the user, select the Access tab, and add the new created role. Save.

Step 2: Set the user's newly created role to be the WebService default role

  1. Log in with an administrator account.

  2. Navigate to Setup > Integration > Web Services Preferences. Select the user, and assign the Web Services Default Role. At this time, this InternalID will be linked automatically. Select Add and Save.

Applies to:

  • Riva Cloud for NetSuite and Exchange or GroupWise.
  • Riva On-Premise for NetSuite and Exchange or GroupWise.

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Article ID: 576
Last updated: 20 Oct, 2016
Revision: 2
Views: 10888
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