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Solution for Oracle Sales Cloud Exception JBO-27023 or JBO-27024 "Failed to Validate" All Rows or a Row

Article ID: 1633
Last updated: 14 Jun, 2017

Issue

In any version of Riva Cloud or Riva On-Premise, one or more errors similar to the following may occur when a supported email system is synced with Oracle Sales Cloud:

Error occurred:
Exception: JBO-27023: Failed to validate all rows in a transaction.
JBO-27024: Failed to validate a row with key oracle.jbo.Key[300000003341680 ] in ActivityEO
JBO-27024: Failed to validate a row with key oracle.jbo.Key[300000003341680 300000001292247 ] in ActivityAssigneeEO
JBO-27004: Attribute set for ReminderPeriod in entity ActivityAssigneeEO failed
JBO-27004: Attribute set for ShowTimeAsCode in entity ActivityAssigneeEO failed

[Appointment] Error - Error occurred updating item: [Unknown]
Exception: JBO-27023: Failed to validate all rows in a transaction.
JBO-27024: Failed to validate a row with key oracle.jbo.Key[300000351785350 ] in OpportunityEO: Attribute Name in Opportunity EO is required.

Error - Error occurred creating item: [Unknown]
Exception: JBO-27023: Failed to validate all rows in a transaction.
JBO-HZ:::HZ_FIRST_OR_LAST_NAME_REQUIRED: You must enter either the first name or last name or both for a person.

Cause

There was a defect in Oracle Sales Cloud.

Solution

Part of Oracle's solution consisted in introducing a new functional privilege, ZMM_MANAGE_ACTIVITY_ALL_ADMIN_PRIV ("Manage Activity All Access Admin").

To implement the solution completely, action is required on your part.

The action required on your part depends on which version of Oracle Sales Cloud you are using: R12 or R11.

R12: Action required on your part

Add the functional privilege ZMM_MANAGE_ACTIVITY_ALL_ADMIN_PRIV ("Manage Activity All Access Admin") to the integration user job role:

To add the functional privilege:

  1. Log in to Sales Cloud as a user with the IT_SECURITY_MANAGER role.

  2. Navigate to Tools > Security Console, and do as follows:

    1. On the Roles tab, search for Sales Administrator.
      This is the copy of this out-of-the-box duty role.
    2. From the drop-down, select Edit Role.
    3. Select Next to proceed to Functional Security Policies.
    4. In the Privilege Name search box, search for Manage Activity All Access Admin.
    5. Select Add Functional Security Policy.
    6. Search All for Manage Activity All Access Admin.
    7. Select Add Selected Privileges, and select Cancel.
    8. Select Next four times, select Save, and select Close.
       
  3. Navigate to Navigator > Tools > Scheduled Processes, and do as follows:

    1. Select Schedule New Process.
    2. From the bottom of the drop-down menu, select Search. In the Name field, enter Send Pending LDAP Requests, and search.
    3. Select the process from the list, and select OK. Select OK again, and select Submit.
    4. Select Schedule New Process.
    5. From the bottom of the drop-down menu, select Search. In the Name field, enter Retrieve Latest LDAP Changes, and search.
    6. Select the process from the list, and select OK. Select OK again, and select Submit.

R11: Action required on your part

Add the functional privilege ZMM_MANAGE_ACTIVITY_ALL_ADMIN_PRIV ("Manage Activity All Access Admin") to the integration user job role:

To add the functional privilege:

  1. Log in to Sales Cloud as a user with the IT_SECURITY_MANAGER role.

  2. Navigate to Setup and Maintenance > Task: Manage Duties > Go to Task, and do as follows:

    1. Search for the Application role named Sales Admin or a custom role for the integration user.
    2. Open, and navigate to the Application Role Hierarchy tab.
    3. Select Find Policies, and navigate to Default Domain.
    4. Under Functional policies, select Targets to navigate to the details.
    5. Select Add Target.
    6. In the Entitlements tab, search for the name ZMM_MANAGE_ACTIVITY_ALL_ADMIN_PRIV.
    7. When you see the result, select it, and add it to the bottom table. Select Add target, and select Apply.
       
  3. In Sales Cloud, navigate to Tools > Scheduled Processes, and do as follows:

    1. Select Schedule New Process.
    2. From the bottom of the drop-down menu, select Search.
    3. In the Name field, enter Retrieve Latest LDAP Changes, and search.
    4. Select the process from the list, and select OK. Select OK again, and select Submit.

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Article ID: 1633
Last updated: 14 Jun, 2017
Revision: 7
Views: 5205
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