Riva CRM Integration - Documentation and Knowledge Base

Error after user moved: Sync aborting - conflicting entity detected

Article ID: 1210
Last updated: 04 Mar, 2015

In rare circumstances, Riva admins have reported conflicting entity errors after moving users between sync policies using one of the following procedures:

In this example, the user Ian Sample is moved between Sync Policy East to Sync Policy West.  When Riva attempts to sync the user, a conflicting entity error is reported:

2015-02-23 12:18:46,359 ERROR [38] [(null)] Sync aborting - conflicting entity detected - EntityName: ian.sample@example.com, Policy: Sync Policy East, Conflicting Policy: Sync Policy West

Cause

This error occurs because the users original sync destination is still in the Riva Global metadata.

Resolution

To resolve this error, the Riva Admin can remove the sync destination metadata files:

  1. In the CRM Service Monitor application, STOP the service.
  2. In Windows Explorer navigate to the \Riva\Transactions\CrmModuleEx\Global\Default\<crmtype> folder.

  3. Delete the syncDestinations.metadata and syncDestinations.metadata-journal files.

  4. In the CRM Service Monitor application, START the service.

  5. Monitor user sync activity and confirm that there is no Sync aborting - conflicting entity detected error.

Applies to

  • Riva On Premise for Exchange
  • Riva On Premise for Notes

Article ID: 1210
Last updated: 04 Mar, 2015
Revision: 1
Views: 4013
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