Riva CRM Integration - Documentation and Knowledge Base

Oracle On Demand: Opportunity creation failed : "Required field is missing ..."

Article ID: 1037
Last updated: 14 Jun, 2019

Issue

In Riva Cloud or Riva On-Premise, the following Oracle CRM On Demand error may occur:

[Opportunity] Error - Error occurred creating item: Required field is missing in instance of Integration Component 'Opportunity' with the user key '':   'SalesStageId' is a required field.
Error- Error occurred creating item: Required field is missing in instance of Integration Component 'Contact' with the user key ":'AccountName' is required field. Please enter a value for the field.

Cause

Error 1: Some Oracle CRM On Demand configurations require that a "SalesStageId" value be set when creating an opportunity. If the field is not present when creating an opportunity, the error occurs.

Error 2: Similar to error 1,  a required field is missing, in this case, the user key: AccountName when creating a contact.

Solution

Error 1: Ensure that when creating opportunities, a default Sales Stage Id be provided. This setting can be defined on the connection details for the Oracle CRM On Demand connection.

Error 2: Ensure that when creating a contact, an AccountName is provided.

Note: There are some default values available for contacts and opportunities with Oracle CRM On Demand but most companies customize these values, and each CRM instance may be different.

Solution for Riva Cloud

To define the SalesStageId value in the Oracle On Demand CRM connection:

  1. In Riva Cloud, edit the Oracle CRM connection.

  2. Add the desired default Sales Stage ID.

  3. Save the changes.

    Riva Cloud applies that value on the next sync cycle for each user.

Solution for Riva On-Premise

To define the Sales Stage ID default value:

  1. Start the Riva Manager application. On the menu bar, select Setup.

  2. In the right pane, double-click the Oracle On Demand connection.

  3. In the window that appears, select Options, and select the Override Opportunity SalesStage Default Value check box.

  4. Save the changes.

  5. In the CRM Monitor application, restart the service.

This article was:   Helpful | Not helpful
Report an issue
Article ID: 1037
Last updated: 14 Jun, 2019
Revision: 5
Views: 4833
Comments: 0
Also listed in