Riva CRM Integration - Documentation and Knowledge Base

Create Case/Opportunity Error: REQUIRED_FIELD_MISSING

Article ID: 943
Last updated: 24 Jun, 2016

Issue

A customer reported that users are finding emails in "- Create New Case" and "- Create Opportunity" email drop folders. Riva fails to sync emails and all emails are assigned the following Riva error category:

Error – [REQUIRED_FIELD_MISSING] Required fields are missing: [Assign_To_c]

Cause

This error is reporting that Riva cannot create the case or opportunity because there is a mandatory field in the CRM create case or create opportunity form that cannot be populated with data. In this example, there is a custom field called "Assign_To_c".

Options to Handle This Error

OPTION 1: Customize Riva

This involves signing a professional services agreement for the Riva developer team to create the Riva server customization to meet your requirements. This is a billable option. Contact the Riva Success Team.

OPTION 2: Customize the CRM

This involves modifying the CRM to do one of the following:

  • Set the custom field(s) as option (not mandatory). Users can then add the custom data after the item is created by Riva; OR

  • Set the custom field(s) to have a default value other than NULL. When Riva creates the item, NetSuite adds the default value because Riva does not specify a value; OR

  • Modify/create workflows in NetSuite to add a value when an item is created by Riva.

OPTION 3: Set the default FORM for the Riva connection user

  1. Create a new form that does not include the required field.

  2. Change the default form assigned to the role used by the Riva connection user.

Then when Riva tries to create a new record, this default form is used - that does not have the required fields.

Article ID: 943
Last updated: 24 Jun, 2016
Revision: 2
Views: 4612